ubuntu缺少captcha相关动态库导致无法渲染的解决办法

ubuntu上安装了jdk后可能会缺少captcha需要的相关so库,导致验证码没有渲染出来,报错信息的其中一部分大概如下

Caused by: java.lang.UnsatisfiedLinkError: /usr/local/jdk1.8.0_221/jre/lib/amd64/libawt_xawt.so: libXtst.so.6: cannot open shared object file: No such file or directory

解决办法是apt install libxtst6

可能还有其他库,根据具体所缺的库进行apt install xxx就可以了

我所用的环境缺了两个库libxtst6和libxi6

评论区