Jfinal Demo 使用了compiler compliance level 1.5

我在使用jfinal Demo过程中,导入项目默认compiler compliance level 1.5。我安装的jdk是1.8,环境变量也配置1.8,compiler compliance level设置1.8以后,项目就报错,也没有具体的错,就是红叉。eclipse 使用了是 4.7.2版本。这是为什么?

360截图16581119797480.png360截图16460526104130109.png360截图16520828677356.png

评论区

lyh061619

2018-01-10 10:12

这个问题自己小配置下就好了:
1、常规项目修改工程属性把默认的编译级别调整为1.8。
2、如果是maven管理项目在pom.xml文件添加默认编译级别为1.8就好了。

mekain

2018-01-10 11:46

@lyh061619 这两个常规的东西,已经设置过了。但是就是项目会报错,只是显示红叉,代码什么的都没有提示错误。

lyh061619

2018-01-10 12:47

@mekain 方便的话,把问题截图出来

mekain

2018-01-10 13:05

lyh061619

2018-01-10 13:08

@mekain 你clear project操作下,不行把项目发到我邮件上去我帮你调试:642574878@qq.com